$re = '/(^SA21 abcdef$)(?!\1)/m';
$str = 'BK udsia
SA21 abcdef
BKxyz
SA21 abcdef';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);