package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+[a-z]?)(\s+.*)`)
var str = `19a smith STREET
19 smith STREET`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}