$re = '/(\d+[a-z]?)(\s+.*)/';
$str = '19a smith STREET
19 smith STREET';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);