const regex = /^(?!\d{6}-?\d{4}$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d{6}-?\\d{4}$).*$', 'gm')
const str = `1234567890
123456-7890
1234567890123
123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}