$re = '/^(?!\d{6}-?\d{4}$).*$/m';
$str = '1234567890
123456-7890
1234567890123
123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);