$re = '/^(?:>=?|<=?)?\d{4}-\d{2}-\d{2}$/m';
$str = '1978-12-20
>1978-12-20
>=1978-12-20
<1978-12-20
<=1978-12-20
=1978-12-20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);