re = /^(?:>=?|<=?)?\d{4}-\d{2}-\d{2}$/m
str = '1978-12-20
>1978-12-20
>=1978-12-20
<1978-12-20
<=1978-12-20
=1978-12-20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end