# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a[^>]*?~dead host~.*?</a>"
test_str = ("There is a bunch of text here. It sure is a pretty day outside. <a href='http://~dead host~/vypdye57f25o' rel='nofollow' target='blank'>part-2</a> The sun is chirping, the birds are shining. It's a glorious day today, indeed.\n\n"
"There once was a man from Nantucket, who kept all his cash in a bucket. <a href=\"http://www.google.com\">Google.com</a> But his daughter named \"Nan\" ran away with a man and as for the bucket, Nan tuck it. <a href=\"http://~dead host~/asdf\">Dead host</a>. Paw followed this pair to Nantucket, the mand and the girl with the bucket, and he said to the man, \"You're welcome to Nan\", but as for the bucket, Paw tuck it. <a href=\"http://www.yahoo.com\">asdf</a>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.