#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[^"]*"|'[^']*'|\b([a-zA-Z_\d]*[a-zA-Z_][a-zA-Z_\d]*)\b"
Local $sString = "example_ _where // matches: example_, _where" & @CRLF & _
"this would "not be matched" // matches: this and would" & @CRLF & _
"while this would // matches: while this would" & @CRLF & _
"while 'this' would // matches: while and would" & @CRLF & _
"this is number 0 // matches: this, is and number" & @CRLF & _
"numb3r f1ve // matches: numb3r and f1ve" & @CRLF & _
"example_ _where // matches: example_ and _where" & @CRLF & _
"this would "not be 9 matched" // matches: this and would" & @CRLF & _
"while 'this' would // matches: while and would"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")