package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"]*"|'[^']*'|\b([a-zA-Z_\d]*[a-zA-Z_][a-zA-Z_\d]*)\b`)
var str = `example_ _where // matches: example_, _where
this would "not be matched" // matches: this and would
while this would // matches: while this would
while 'this' would // matches: while and would
this is number 0 // matches: this, is and number
numb3r f1ve // matches: numb3r and f1ve
example_ _where // matches: example_ and _where
this would "not be 9 matched" // matches: this and would
while 'this' would // matches: while and would`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}