const regex = /^(\d*\.)?\d+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*\\.)?\\d+$', 'gmi')
const str = `5.1
234.23425
0.234
.6454
45
0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}