$re = '/^(\d*\.)?\d+$/mi';
$str = '5.1
234.23425
0.234
.6454
45
0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);