package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:NN\s+)+)IN\s+NN`)
var str = `DT NN IN NN"
NN IN NN"
NN NN IN NN"
NN IN NN NN NN"
NN NN IN NN NN"
NN IN CD NN"
CD NN IN CD NN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}