$re = '/^((?:NN\s+)+)IN\s+NN/m';
$str = 'DT NN IN NN"
NN IN NN"
NN NN IN NN"
NN IN NN NN NN"
NN NN IN NN NN"
NN IN CD NN"
CD NN IN CD NN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);