using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"j?(a?(va))";
string input = @"this is java. this is ava, this is va";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}