$re = '/j?(a?(va))/';
$str = 'this is java. this is ava, this is va';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);