const regex = /^5[1-5][0-9]{14}|5[0-9][0-9]{14}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^5[1-5][0-9]{14}|5[0-9][0-9]{14}$', '')
const str = `5999999999999101`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}