import re
regex = re.compile(r"^5[1-5][0-9]{14}|5[0-9][0-9]{14}$")
test_str = "5999999999999101"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")