re = /@(.+?):/
str = 'rainyear@hotmail.com:pepper
rajkomatt3@gmail.com:wehttam12
rakkasan240b@gmail.com:dn38416
rallytruckgnome@gmail.com:urban12
rammer388@gmail.com:ryanm08
ramonlopezjr@gmail.com:26may2001
ramsec@live.com:ramseywii1
randomhulu@gmail.com:moppel12
rangeman101@hotmail.co.uk:warcraft4
rangerkid1997@gmail.com:fetherolf5432
ranglinm@yahoo.com:rang94631
raphhashem@gmail.com:31951raph
rappe.austin@gmail.com:Elle4637096
ratof81@gmail.com:lovecraft1
raxarraxar@gmail.com:48oakao42
raylonlong@gmail.com:rayray12
rayvale.games@googlemail.com:fDbXh87Xfn
ray_2096@hotmail.com:hardys1996
rbenade@hotmail.ca:bandstra1
rcolegreco@gmail.com:Hell0W0rld
rdfenton@hotmail.com:scoots55
'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result