using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#mp-[^#\s]+)";
string input = @"www.site.com/#mp-1
www.site.com#mp-1
www.site.com/#mp-1#pic";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}