$re = '/(#mp-[^#\s]+)/';
$str = 'www.site.com/#mp-1
www.site.com#mp-1
www.site.com/#mp-1#pic';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);