$re = '/\+(?=[^()]*\))/m';
$str = '(a+b)*3+7';
$subst = "plus";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;