import Foundation
let pattern = #"\+(?=[^()]*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"(a+b)*3+7"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"plus"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)