$re = '/([A-Z]+)(?=\s+\S+\s+\S+\s+(\S+)\s+\S+\s+\S+\s+(\S+))/m';
$str = 'ABC FED GHK 45.00 60.00 30.00 4 5 5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);