re = /([A-Z]+)(?=\s+\S+\s+\S+\s+(\S+)\s+\S+\s+\S+\s+(\S+))/m
str = 'ABC FED GHK 45.00 60.00 30.00 4 5 5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end