package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bHelloWorld\b`)
var str = `HelloWorld is a beautiful word\nHelloWorld\t\t\tHelloWorld HelloWorld \t HelloWorld nopHelloWorld HelloWorldnop \tnopHelloWorld ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}