re = /\bHelloWorld\b/
str = 'HelloWorld is a beautiful word\\nHelloWorld\\t\\t\\tHelloWorld HelloWorld \\t HelloWorld nopHelloWorld HelloWorldnop \\tnopHelloWorld ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end