const regex = /\s+From: F3[\w\W]+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+From: F3[\\w\\W]+', 'i')
const str = `PS – extra nice work on this one! 😊
Thank you !
From: F3 test <test@test.com>
Sent: Thursday, October 3, 2024 4:13 PM
To: test <test@test.com>
Subject: Re: Question
Good afternoon,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}