use strict;
my $str = 'PS – extra nice work on this one! 😊
Thank you !
From: F3 test <test@test.com>
Sent: Thursday, October 3, 2024 4:13 PM
To: test <test@test.com>
Subject: Re: Question
Good afternoon,';
my $regex = qr/\s+From: F3[\w\W]+/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}