package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w\W]*)<FooBar>`)
var str = `abcde
fghij<FooBar>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}