$re = '/^193\.172\.166\.([1-2][0-9]|3[0-1]|[0-9])$/mi';
$str = '193.172.166.0
193.172.166.9
193.172.166.11
193.172.166.31
193.172.166.32
193.172.166.45
193.172.166.100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);