$re = '/^\s*-?\d+(?:\s*[-+*\/]\s*\d+)+$/m';
$str = '1+3/2-1
21 - 5 -6*8
21
21+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);