// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*-?\d+(?:\s*[-+*\/]\s*\d+)+$").unwrap();
let string = "1+3/2-1
21 - 5 -6*8
21
21+
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}