using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}";
string input = @"from mail.example.com (example.com. [213.239.250.131]) by
mx.google.com with ESMTPS id xc4si15480310lbb.82.2014.10.26.06.16.58 for
<alex@example.com> (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256
bits=128/128); Sun, 26 Oct 2014 06:16:58 -0700 (PDT)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}