import re
regex = re.compile(r"(?:[a-z0-9]{1,4}:+){3,5}[a-z0-9]{1,4}|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}")
test_str = ("from mail.example.com (example.com. [213.239.250.131]) by\n"
" mx.google.com with ESMTPS id xc4si15480310lbb.82.2014.10.26.06.16.58 for\n"
" <alex@example.com> (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256\n"
" bits=128/128); Sun, 26 Oct 2014 06:16:58 -0700 (PDT)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")