import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(?:s)?://(?:www\\.)?facebook.(?:[a-z]+)/(?!(?:video\\.php\\?v=\\d+|usernameFB/videos/\\d+)).*$";
final String string = "https://www.facebook.com/video.php?v=100000000000000\n"
+ "https://www.facebook.com/username1/videos/100000000000000\n"
+ "https://www.facebook.com/username2/videos/100000000000000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}