use strict;
my $str = 'https://www.facebook.com/video.php?v=100000000000000
https://www.facebook.com/username1/videos/100000000000000
https://www.facebook.com/username2/videos/100000000000000
';
my $regex = qr~^http(?:s)?://(?:www\.)?facebook.(?:[a-z]+)/(?!(?:video\.php\?v=\d+|usernameFB/videos/\d+)).*$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}