package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s()-]*$`)
var str = `12332345
12(34)
123ksdhkow
12-3456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}