$re = '/^[^\s()-]*$/m';
$str = '12332345
12(34)
123ksdhkow
12-3456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);