# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(754|1231)|[^A-Za-z\s]"
test_str = ("Dividends 9672\n"
"Dividends 9680\n"
"Interest Income\n"
"Ordinary Dividends\n"
"Royalties\n"
"Capital Gain Distributions\n"
"Income from Blackstone\n"
"Ordinary Income\n"
"Rental Income\n"
"Long Term Capital Gain\n"
"Short Term Capital Gain\n"
"1231 Gain\n"
"Section 754 Stock Basis Adjustment - 2015\n"
"M-1 Section 754 Stock Basis Adjustment - 2015\n"
"Section 754 Stock Basis Adjustment - 2018\n"
"M-1 Section 754 Stock basis adjustment - 2018")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.