// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"https?:\/\/[^"]*"#).unwrap();
let string = "{ \"uploadUrl\": \"https://streetviewpublish.googleapis.com/media/user/11705162112362643904472027/photo/899853939832211842569886\" }";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}