using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\p{L}\p{Nd}\p{P}\p{S}]+";
string input = @"? Hello
- Testing
! EXCLAMATION
£test
$dollar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}