import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\p{L}\\p{Nd}\\p{P}\\p{S}]+";
final String string = "? Hello\n"
+ "- Testing\n"
+ "! EXCLAMATION\n"
+ "£test\n"
+ "$dollar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}