using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"word=([a-zA-Z_-]+)";
string input = @"word=aaa
word=aaa
word=a-aa
word=aaa_
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}