package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`word=([a-zA-Z_-]+)`)
var str = `word=aaa
word=aaa
word=a-aa
word=aaa_
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}