import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^ \\>]++) ?[^>]*+>(.*?(?:<([^ \\>]++) ?[^>]*+>(?:[^<]*+|(?2))<\\/ ?\\3>|<[^ \\/>]++ ?\\/>).*?)<\\/ ?\\1>";
final String string = "<a>\n"
+ " <b>\n"
+ " <c>\n"
+ " <d>\n"
+ " <e>\n"
+ " </e>\n"
+ " </d>\n"
+ " </c>\n"
+ " </b>\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}