re = /<([^ \>]++) ?[^>]*+>(.*?(?:<([^ \>]++) ?[^>]*+>(?:[^<]*+|(?2))<\/ ?\3>|<[^ \/>]++ ?\/>).*?)<\/ ?\1>/
str = '<a>
<b>
<c>
<d>
<e>
</e>
</d>
</c>
</b>
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end