package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0\d-\d{4}-\d{4}`)
var str = `01-2345-6789`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}