$re = '/0\d-\d{4}-\d{4}/';
$str = '01-2345-6789';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);