package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*[0-9 |]*\s*#[ \t]*include\s*[<"](\S+)[">]`)
var str = `... fatal error: Foobar.h: No such file or directory
#include <Foobar.h>
test.c:2:10: fatal error: 'file.h' file not found
2 | #include <file.h>
| ^~~~~~~~
1 error generated.
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
... fatal error: Foobar.h: No such file or directory
2 | #include <Foobar.h>
test.c:3:4: error: expected identifier or '('
3 | an "unrelated" error
| ^
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}